re = /(\w+)\s+("[^"]*"|[^\s;]+)/m
str = 'cheese "stilton";pigeons 17; color "blue"; why "because I said so";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end