import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Vous\\savez\\srecu\\sun\\stransfert\\sde\\s(?P<amount>\\d+)FCFA\\sde\\s(?P<sender_name>.*)\\s\\((?P<sender_phone>\\d+)\\)\\sle\\s(?P<when>.*?)\\..*ID.*transaction\\s.*?(?P<transaction_id>\\d+)\\.*";
final String string = "Vous avez recu un transfert de 12300FCFA de Comlan Louis Barthelemy Djihoulande (22997870329) le 2023-06-25 11:26:57. Reference: d. Nouveau solde: 20120 FCFA. ID de la transaction : 5041378775..";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}