#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\b(?=\w*[epo])[epo]*+[^\Wepo]?+[epo]*\b"
Local $sString = "PPEEOX" & @CRLF & _
"PO" & @CRLF & _
"POX" & @CRLF & _
"EEP" & @CRLF & _
"PPPXY" & @CRLF & _
"XYP" & @CRLF & _
"POXP" & @CRLF & _
"POEEEEEE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")