using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=\w*[epo])[epo]*+[^\Wepo]?+[epo]*\b";
string input = @"PPEEOX
PO
POX
EEP
PPPXY
XYP
POXP
POEEEEEE";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}