$re = '/\b(?=\w*[epo])[epo]*+[^\Wepo]?+[epo]*\b/mi';
$str = 'PPEEOX
PO
POX
EEP
PPPXY
XYP
POXP
POEEEEEE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);