import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\?php(?!\\S)((?:(?!<\\?php(?!\\S)|\\?>).)*\\R[\\s\\S]*?)\\?>";
final String string = "Test number <?PHP echo($a);?> is here.\n\n"
+ "This is test number <?PHP echo($b);\n"
+ "$b = $a?> that expanded across multiple lines.\n\n"
+ "This is test number <?PHP\n"
+ " echo($b);\n"
+ "$b = $a?> that expanded across multiple lines.\n\n"
+ "This is test number <?PHP\n"
+ " $b = $a?> that expanded across multiple lines.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}