$re = '/<\?php(?!\S)((?:(?!<\?php(?!\S)|\?>).)*\R[\s\S]*?)\?>/i';
$str = 'Test number <?PHP echo($a);?> is here.
This is test number <?PHP echo($b);
$b = $a?> that expanded across multiple lines.
This is test number <?PHP
echo($b);
$b = $a?> that expanded across multiple lines.
This is test number <?PHP
$b = $a?> that expanded across multiple lines.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);