re = /<\?php(?!\S)((?:(?!<\?php(?!\S)|\?>).)*\R[\s\S]*?)\?>/i
str = 'Test number <?PHP echo($a);?> is here.
This is test number <?PHP echo($b);
$b = $a?> that expanded across multiple lines.
This is test number <?PHP
echo($b);
$b = $a?> that expanded across multiple lines.
This is test number <?PHP
$b = $a?> that expanded across multiple lines.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end