#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)$"
Local $sString = "123.23.10.x" & @CRLF & _
"123.23.x.x" & @CRLF & _
"123.x.x.x"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")