const regex = /^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)$', 'gm')
const str = `123.23.10.x
123.23.x.x
123.x.x.x`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}