import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|x)$";
final String string = "123.23.10.x\n"
+ "123.23.x.x\n"
+ "123.x.x.x";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}