const regex = /\d+_\D+(?=_)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+_\\D+(?=_)', 'gm')
const str = `84_RUNNING_SS19_Fam11887_380x900 de_de idcom2u130937`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}