re = /\d+_\D+(?=_)/m
str = '84_RUNNING_SS19_Fam11887_380x900 de_de idcom2u130937'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end