import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\D*(?:python|php))\\D*(\\d+)\\s?([^\\W\\d_]+)\\s?(\\d{2}\\s?\\d{3})\\s?(\\w+)";
final String string = "45 python 00222 sometext\n"
+ "python white 45 regex 00 222 somewhere\n"
+ "php noise 45 python 65000 sm\n"
+ "otherword 45 python 50000 sm\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}