re = /^(?!\D*(?:python|php))\D*(\d+)\s?([^\W\d_]+)\s?(\d{2}\s?\d{3})\s?(\w+)/m
str = '45 python 00222 sometext
python white 45 regex 00 222 somewhere
php noise 45 python 65000 sm
otherword 45 python 50000 sm
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end