package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<my_field>.*)\d{8}`)
var str = `value02132018additionaltext`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}