$re = '/(?<my_field>.*)\d{8}/';
$str = 'value02132018additionaltext';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);