const regex = /(?<my_field>.*)\d{8}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<my_field>.*)\\d{8}', 'g')
const str = `value02132018additionaltext`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}