package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@([\w.-]+)\.`)
var str = `0m3r.0m3r@0m3r-0m3r.com
0m3r@0m3r.com
0m3r_0m3r@0m3r_0m3r.com
transport@us.inditex.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}