const regex = new RegExp('@([\\w.-]+)\\.', 'gm')
const str = `0m3r.0m3r@0m3r-0m3r.com
0m3r@0m3r.com
0m3r_0m3r@0m3r_0m3r.com
transport@us.inditex.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}