re = /@([\w.-]+)\./m
str = '0m3r.0m3r@0m3r-0m3r.com
0m3r@0m3r.com
0m3r_0m3r@0m3r_0m3r.com
transport@us.inditex.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end