import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[?&;])(?!(param1))(.*)=.*?($|[&;])";
final String string = "https://www.so.com?param2=2¶m1=1\n"
+ "https://www.so.com?param1=1\n"
+ "https://www.so.com?param1=1¶m2=2\n"
+ "https://www.so.com?param1=1¶m2=2¶m3=3\n"
+ "https://www.so.com?param3=3¶m1=1¶m2=2\n"
+ "https://www.so.com?param3=3¶m2=2¶m1=1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}