import re
regex = re.compile(r"(?<=[?&;])(?!(param1))(.*)=.*?($|[&;])", flags=re.MULTILINE)
test_str = ("https://www.so.com?param2=2¶m1=1\n"
"https://www.so.com?param1=1\n"
"https://www.so.com?param1=1¶m2=2\n"
"https://www.so.com?param1=1¶m2=2¶m3=3\n"
"https://www.so.com?param3=3¶m1=1¶m2=2\n"
"https://www.so.com?param3=3¶m2=2¶m1=1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")