$re = '/(?<=[?&;])(?!(param1))(.*)=.*?($|[&;])/m';
$str = 'https://www.so.com?param2=2¶m1=1
https://www.so.com?param1=1
https://www.so.com?param1=1¶m2=2
https://www.so.com?param1=1¶m2=2¶m3=3
https://www.so.com?param3=3¶m1=1¶m2=2
https://www.so.com?param3=3¶m2=2¶m1=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);