import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Processo\\sNº\\s[a-zA-Z]{5,9}-[0-9]{7}-[0-9]{2}.[0-9]{4}.[0-9]{1}.[0-9]{2}.[0-9]{4}[^a-zA-Z]";
final String string = "Precatórios e RPV\n"
+ "AVENIDA DE MARQUES SAO VICENTE , 235, 19 andar - Bloco B,\n"
+ "VARZEA DA BARRA FUNDA, SAO PAULO/SP - CEP: 01139-001\n"
+ "- secprecatorio@trtsp.jus.br\n"
+ "Destinatário: PEDRO CARLOS LUCAS\n"
+ "INTIMAÇÃO - Processo PJe\n"
+ "Processo: 0148400-36.2009.5.02.0041 - Processo PJe\n"
+ "Autor: PEDRO CARLOS LUCAS\n"
+ "Réu: FUNDACAO PRO-SANGUE HEMOCENTRO DE SAO PAULO\n"
+ "Fica V. Sª. intimado(a) dos id’s:\n"
+ "SAO PAULO/SP, 09 de novembro de 2022.\n"
+ "SAO PAULO/SP, 09 de novembro de 2022.\n"
+ "ENIO MARQUES\n"
+ "Servidor\n"
+ "Processo Nº ATOrd-0148400-36.2009.5.02.0041\n"
+ "RECLAMANTE PEDRO CARLOS LUCAS\n"
+ "ADVOGADO Marcia Regina Covre(OAB:\n"
+ "108818/SP)\n"
+ "RECLAMADO FUNDACAO PRO-SANGUE\n"
+ "HEMOCENTRO DE SAO PAULO\n"
+ "ADVOGADO MARINA MEGALE(OAB: 221085/SP)\n"
+ "ADVOGADO CAROLINA KIRALY SANCHEZ(OAB:\n"
+ "278463/SP)\n"
+ "ADVOGADO JOSE BARBUTO NETO(OAB:\n"
+ "207975/SP)\n"
+ "Intimado(s)/Citado(s): Processo Nº ATOrd-0148400-36.2009.5.02.0042\n"
+ " - FUNDACAO PRO-SANGUE HEMOCENTRO DE SAO PAULO\n"
+ " PODER JUDICIÁRIO\n"
+ " JUSTIÇA DO\n"
+ "PODER JUDICIÁRIO FEDERAL\n"
+ "Justiça do Trabalho - 2ª Região\n"
+ "Precatórios e RPV\n"
+ "AVENIDA DE MARQUES SAO VICENTE , 235, 19 andar - Bloco B,VARZEA DA BARRA FUNDA, SAO PAULO/SP - CEP: 01139-001\n"
+ "- secprecatorio@trtsp.jus.br\n"
+ "Destinatário: FUNDACAO PRO-SANGUE HEMOCENTRO DE SAO\n"
+ "PAULO\n"
+ "INTIMAÇÃO - Processo PJe\n"
+ "Processo: 0148400-36.2009.5.02.0041 - Processo PJe\n"
+ "Autor: PEDRO CARLOS LUCAS\n"
+ "Réu: FUNDACAO PRO-SANGUE HEMOCENTRO DE SAO PAULO\n"
+ "Fica V. Sª. intimado(a) dos id’s:778674a\n"
+ "SAO PAULO/SP, 09 de novembro de 2022.\n"
+ "SAO PAULO/SP, 09 de novembro de 2022.\n"
+ "ENIO MARQUES\n"
+ "Servidor\n"
+ "Processo Nº ATOrd-0076600-43.2003.5.02.0045\n"
+ "RECLAMANTE PAULO ROBERTO VENDRAMI\n"
+ "ADVOGADO JAIZA DOMINGAS\n"
+ "GONCALVES(OAB: 55633/SP)\n"
+ "RECLAMADO DEPARTAMENTO AEROVIARIO DO\n"
+ "Processo Nº ATOrd-0148400-36.2009.5.02.0043Lula";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}