use strict;
my $str = 'What is the.What is thef.How did youDo that?F';
my $regex = qr/(?<=[a-z])\.+(?=[A-Z])/mp;
my $subst = '.\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";