re = /(?<=[a-z])\.+(?=[A-Z])/m
str = 'What is the.What is thef.How did youDo that?F'
subst = '.\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result