import Foundation
let pattern = #"(?<=[a-z])\.+(?=[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"What is the.What is thef.How did youDo that?F"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)