import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "IE(?:[\\d]{7}(?:[A-Z]{1,2})|\\d[A-Z][\\d]{5}[A-Z])";
final String string = "IE1234567U\n"
+ "IE1U23456U\n"
+ "IE1234567UU";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}