$re = '/IE(?:[\d]{7}(?:[A-Z]{1,2})|\d[A-Z][\d]{5}[A-Z])/m';
$str = 'IE1234567U
IE1U23456U
IE1234567UU';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);