re = /IE(?:[\d]{7}(?:[A-Z]{1,2})|\d[A-Z][\d]{5}[A-Z])/m
str = 'IE1234567U
IE1U23456U
IE1234567UU'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end