package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\[[^\]]+\]\s*)*\$\w+`)
var str = `[CmdletBinding()]
Param([Parameter(Mandatory=$True,Position=1)][string]$computerName,[Parameter(Mandatory=$True)][string]$filePath)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}