$re = '`(?:\[[^\]]+\]\s*)*\$\w+`';
$str = '[CmdletBinding()]
Param([Parameter(Mandatory=$True,Position=1)][string]$computerName,[Parameter(Mandatory=$True)][string]$filePath)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);