re = /(?:\[[^\]]+\]\s*)*\$\w+/
str = '[CmdletBinding()]
Param([Parameter(Mandatory=$True,Position=1)][string]$computerName,[Parameter(Mandatory=$True)][string]$filePath)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end