#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b162=\d+(?:\|\d+=\d+)+?\|4562=\d+"
Local $sString = "120=3|162=0|181=1|72=24842|23=125|40=119|155=2321|130=3|105=1|4562=1|162=2|181=1|72=24842|23=125|40=120|155=2322|130=5|105=1|4562=2|162=0|181=1|72=24842|23=125|40=121|155=2326|130=2|105=1|4562=10|100=087|\n" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")