// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b162=\d+(?:\|\d+=\d+)+?\|4562=\d+").unwrap();
let string = "120=3|162=0|181=1|72=24842|23=125|40=119|155=2321|130=3|105=1|4562=1|162=2|181=1|72=24842|23=125|40=120|155=2322|130=5|105=1|4562=2|162=0|181=1|72=24842|23=125|40=121|155=2326|130=2|105=1|4562=10|100=087|\\n
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}