$re = '/\b162=\d+(?:\|\d+=\d+)+?\|4562=\d+/';
$str = '120=3|162=0|181=1|72=24842|23=125|40=119|155=2321|130=3|105=1|4562=1|162=2|181=1|72=24842|23=125|40=120|155=2322|130=5|105=1|4562=2|162=0|181=1|72=24842|23=125|40=121|155=2326|130=2|105=1|4562=10|100=087|\\n
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);