using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\W*\b[A-Z]+\b(?!'\b)\.?";
string substitution = @"";
string input = @"John O'Connele MCA,MD.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}