const regex = /\W*\b[A-Z]+\b(?!'\b)\.?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\W*\\b[A-Z]+\\b(?!\'\\b)\\.?', 'gm')
const str = `John O'Connele MCA,MD.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);