use strict;
my $str = 'saleforces
abcdefg
123456789';
my $regex = qr/(?<=..)./p;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";