package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:([^\s=]+)=)?(.+)`)
var str = `key1=value1
value_only_no_key
key2=value2=containing=equal=signs`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}