re = /^(?:([^\s=]+)=)?(.+)/m
str = 'key1=value1
value_only_no_key
key2=value2=containing=equal=signs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end