$re = '/^(?:([^\s=]+)=)?(.+)/m';
$str = 'key1=value1
value_only_no_key
key2=value2=containing=equal=signs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);