import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:https?:\\/\\/)?(?:www\\.)?domain\\.com(?!\\S*\\?))(\\S*)";
final String string = "www.domain.com dsa dsad sad sad sa\n"
+ "domain.com asdasds adas dsa\n"
+ "www.domain.com/someurl/?d sad sadsad\n"
+ "www.domain.com/someurl/ asd asd sa\n"
+ "www.domain.com?id=123 sd asdsa d<hr>\n";
final String subst = "$1$2?add_text";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}