re = /((?:https?:\/\/)?(?:www\.)?domain\.com(?!\S*\?))(\S*)/im
str = 'www.domain.com dsa dsad sad sad sa
domain.com asdasds adas dsa
www.domain.com/someurl/?d sad sadsad
www.domain.com/someurl/ asd asd sa
www.domain.com?id=123 sd asdsa d<hr>
'
subst = '$1$2?add_text'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result