const regex = /((?:https?:\/\/)?(?:www\.)?domain\.com(?!\S*\?))(\S*)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:https?:\\\/\\\/)?(?:www\\.)?domain\\.com(?!\\S*\\?))(\\S*)', 'gim')
const str = `www.domain.com dsa dsad sad sad sa
domain.com asdasds adas dsa
www.domain.com/someurl/?d sad sadsad
www.domain.com/someurl/ asd asd sa
www.domain.com?id=123 sd asdsa d<hr>
`;
const subst = `$1$2?add_text`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);