using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Server Version: \K\d+(?:\.\d+)+(?= Kubernetes)";
string input = @"Client Version: openshift-clients-4.3.0-201910250623-88-g6a937dfe Server Version: 4.3.0 Kubernetes Version: v1.16.2:q";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}