# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w+)(\:)"
test_str = (" options: [{\n"
" value: \"120\",\n"
" id: \"40\",\n"
" title: \"1400g\",\n"
" name: \"Tamanho\"\n"
" },\n"
" {\n"
" value: \"336\",\n"
" id: \"60\",\n"
" title: \"Chocolate\",\n"
" name: \"Sabor\"\n"
" }\n"
" ]")
subst = "\\\"$1\\\"$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.