#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "!php/const:?\s*([a-zA-Z\\_]+(::[a-zA-Z_]+)?)+(:\s*(.*))?"
Local $sString = "parameters:" & @CRLF & _
" class_constant: !php/const Symplify\ConfigTransformer\Tests\Converter\ConfigFormatConverter\YamlToPhp\YamlToPhpTest::TEST" & @CRLF & _
" class: !php/const Symplify\ConfigTransformer\Tests\Converter\ConfigFormatConverter\YamlToPhp\YamlToPhpTest::class" & @CRLF & _
" class2: !php/const:Symplify\ConfigTransformer\Tests\Converter\ConfigFormatConverter\YamlToPhp\YamlToPhpTest::class" & @CRLF & _
" const: !php/const PHP_INT_MAX" & @CRLF & _
" const2: !php/const:PHP_INT_MAX" & @CRLF & _
" unexisting_constant: !php/const SomeClass::Constant" & @CRLF & _
" !php/const PHP_INT_MAX: some_value" & @CRLF & _
" !php/const App\Entity\Plant::TRANSITION_PLANT: some_value" & @CRLF & _
" !php/const:App\Entity\Plant::TRANSITION_TWO: some_value"
Local $sSubst = "%const($1)$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)