re = /!php\/const:?\s*([a-zA-Z\\_]+(::[a-zA-Z_]+)?)+(:\s*(.*))?/
str = 'parameters:
class_constant: !php/const Symplify\\ConfigTransformer\\Tests\\Converter\\ConfigFormatConverter\\YamlToPhp\\YamlToPhpTest::TEST
class: !php/const Symplify\\ConfigTransformer\\Tests\\Converter\\ConfigFormatConverter\\YamlToPhp\\YamlToPhpTest::class
class2: !php/const:Symplify\\ConfigTransformer\\Tests\\Converter\\ConfigFormatConverter\\YamlToPhp\\YamlToPhpTest::class
const: !php/const PHP_INT_MAX
const2: !php/const:PHP_INT_MAX
unexisting_constant: !php/const SomeClass::Constant
!php/const PHP_INT_MAX: some_value
!php/const App\\Entity\\Plant::TRANSITION_PLANT: some_value
!php/const:App\\Entity\\Plant::TRANSITION_TWO: some_value'
subst = '%const($1)$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result